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®

Select a product category to get started

Monitor Arm Specification Tool

]
The fluid, dynamic movement of Flo monitor arms The Wishbone monitor arm frees up worksurface
can precisely adjust the position of one or multiple space, while allowing you to position the screen
screens with minimal effort. The intuitive fingertip at the proper distance to ease neck and eye strain.
control quickly covers a wide range of motion to A combination of robust engineering and precise
create the optimal position for everyone’s eyes, controls position screens right where you need
even those with progressive lenses. them, and keeps them firmly in place.
Dynamic Arms » Static Arms »
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Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

0 - 3 kgs
3 -9 kgs

9 - 18 kgs

* White finish option is available in select models.
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Dynamic Monitor Arms
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Dynamic Monitor Arms

Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

White
0-3kgs Silver
Black

* White and Black finish options are available in select models.

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: O - 3 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: O - 3 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: O - 3 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

White
3 -9kgs Silver
Black

* White and Black finish options are available in select models.
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: 3 - 9 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

Dynamic Arms: 3 - 9 kgs

Will you need to accommodate weights from o - 9 kgs?

* White and Black finish options are available in select models.

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

Dynamic Arms: 3 - 9 kgs - 2 monitors

Will you need to accommodate weights from o - 9 kgs?

* White and Black finish options are available in select models.

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: 3 - 9 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

{ Back



®

Dynamic Monitor Arms

Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

Dynamic Arms: 3 - 9 kgs

Will you need to accommodate weights from o - 9 kgs?

* White and Black finish options are available in select models.

{ Back




®

Dynamic Monitor Arms

Dynamic Monitor Arms

Select your weight requirement
and preferred support finish”

Dynamic Arms: 3 - 9 kgs - 2 monitors

Will you need to accommodate weights from o - 9 kgs?

* White and Black finish options are available in select models.

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: 3 - 9 kgs — 2 monitors

Select your monitor size requirement.

Under 22 inches 22 inches and above

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: 3 - 9 kgs — 2 monitors

Do you need your monitors to move
in tandem or independently?

In Tandem Independently

{ Back
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: 3 - 9 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

< Back @
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Dynamic Monitor Arms

Dynamic Monitor Arms

Dynamic Arms: 9 - 18 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

{ Back
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Your Dynamic Arm Results:

Flo Single Monitor Arm

Mount: Surface Clamp Finish: White

View in Silver Finish »
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http://www.hermanmiller.com/products/accessories/technology-support/flo-monitor-supports.html
mailto:jan%40cre8.cz?subject=Tell%20me%20more%20about%20Flo%20Single%20Monitor%20Support
https://www.hermanmiller.com/en_gb/products/accessories/technology-support/flo-monitor-arms/

®

Flo® Single Monitor Arm

Dynamic Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment \
bracket — accounting for 80% of Flo sales. This
attachment style allows monitors to be spaced /

anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Rail Tile Wall Mount Locale

{ Return to Main Menu | More Information >  Email HMI Sales > @
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Your Dynamic Arm Results:

Flo Single Monitor Arm

Mount: Surface Clamp Finish: Silver

View in White Finish »
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®

Flo® Single Monitor Arm

Dynamic Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of Flo sales. This
attachment style allows monitors to be spaced
anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Rail Tile Wall Mount Locale

{ Return to Main Menu | More Information >  Email HMI Sales > @
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Your Dynamic Arm Results:

Flo® Plus Single Monitor Arm

Mount: Surface Clamp Finish: Silver
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* Variant available with maximum weight range of up to 15kgs

. . . (B (@)
{ Return to Main Menu |  More Information >  Email HMI Sales > WIS I®
HermanMiller
Authorised Accredited Partner


http://www.hermanmiller.com/products/accessories/technology-support/flo-monitor-supports.html
https://www.hermanmiller.com/en_gb/products/accessories/technology-support/flo-monitor-arms/
mailto:jan%40cre8.cz?subject=Tell%20me%20more%20about%20Flo%20Single%20Monitor%20Support

®

Your Dynamic Arm Results:

Ollin® Single Monitor Arm

Mount: Surface Clamp Finish: White

View in Silver Finish »
View in Black Finish »

Mount Options » All Dynamic Single Arms »

< Return to Main Menu | More Information )
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®

Ollin® Single Monitor Arm

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Dynamic Monitor Arms

Through Mount Grommet

< Return to Main Menu | More Information )
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Your Dynamic Arm Results:

Ollin® Single Monitor Arm

Mount: Surface Clamp Finish: Black

View in Silver Finish »
View in White Finish »

< Return to Main Menu | More Information )
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Mount Options » All Dynamic Single Arms »
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Ollin® Single Monitor Arm

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Dynamic Monitor Arms

Through Mount Grommet

< Return to Main Menu | More Information )

Email HMI Sales »

1 /\\ (m\
J\:‘ \\ /7

Q Mll
ed Accredite


mailto:jan%40cre8.cz?subject=Tell%20me%20more%20about%20OllinSingle%20Monitor%20Support
https://www.hermanmiller.com/en_gb/products/accessories/technology-support/ollin-monitor-arms/

®

Your Dynamic Arm Results:

Ollin® Single Monitor Arm

Mount: Surface Clamp Finish: Silver

View in White Finish »
View in Black Finish »
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®

Ollin® Single Monitor Arm

Dynamic Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment {
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be

spaced anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet

. . . (B (@)
{ Return to Main Menu |  More Information >  Email HMI Sales > (G ()
HermanMiller
Authorised Accredited Partner


mailto:jan%40cre8.cz?subject=Tell%20me%20more%20about%20OllinSingle%20Monitor%20Support
https://www.hermanmiller.com/en_gb/products/accessories/technology-support/ollin-monitor-arms/

! Dynamic Monitor Arms

Dynamic Monitor Arm
Single Monitor Arm Options

Flo Single Monitor Arm Flo Plus Single Monitor Arm Ollin Single Monitor Arm

Flo Single is recommended for monitors The Flo Plus Single is ideal for monitor As technology advances, devices become

between 3 and 9 kgs and is available in workspaces that require a dynamic arm lighter and more compact. With the Ollin

multiple mount options and white and ranging from 9 - 18 kgs. If using an Apple Monitor Arm, you can support a range of

silver finishes. monitor, please visit Apple’s website to monitors and laptops from O - 9 kg. The arm
check for compatibility, as these monitors has a wide range of motion, including the
require an adapter plate from Apple. ability to rotate landscape or portrait.

View » View » View »
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®

Your Dynamic Arm Results:

2 Flo® Single Monitor Arms

Mount: Surface Clamp Finish: White

View in Silver Finish »
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2 Flo® Single Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of Flo sales. This
attachment style allows monitors to be spaced
anywhere along the back edge of the desk.

Using the Surface Clamp to mount Flo Single Monitor
Arms for 2 screens gives you the most flexibility for
your workspace. Mount your screens closer together
to spread your project over the space of both screens,
or allow for more desktop space by spacing your
mounts farther apart.

< Return to Main Menu | More Information )
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Your Dynamic Arm Results:

2 Flo® Single Monitor Arms

Mount: Surface Clamp Finish: Silver

View in White Finish »
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2 Flo® Single Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of Flo sales. This
attachment style allows monitors to be spaced
anywhere along the back edge of the desk.

Using the Surface Clamp to mount Flo Single Monitor
Arms for 2 screens gives you the most flexibility for
your workspace. Mount your screens closer together
to spread your project over the space of both screens,
or allow for more desktop space by spacing your
mounts farther apart.

< Return to Main Menu | More Information )
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®

Your Dynamic Arm Option 1:

Flo° Dual Monitor Arm

Mount: Surface Clamp

Email HMI Sales »

For a dual screen workspace with a clean aesthetic, the
Flo Dual offers a compact support system with a maximum
recommended screen size of 22” and under.

{ Return to Main Menu

Finish: Silver

Available in Surface Clamp Only

| More Information »

All Dynamic Dual Supports )

Your Dynamic Arm Option 2:
Flo" Dual Monitor Modular Arm

Mount: Surface Clamp Finish: Silver

Email HMI Sales » Additional Mount Options »

For workspaces with monitors 22” and under that require
additional attachment solutions, the Flo Dual Modular
offers more flexibility to fit any desktop.
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®

Flo° Dual Monitor Modular Arm

Dynamic Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of Flo sales. This
attachment style allows monitors to be spaced
anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Locale

{ Return to Main Menu | More Information >  Email HMI Sales > @
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Your Dynamic Arm Results:

Flo° Plus Dual Monitor Arm

Mount: Surface Clamp Finish: Silver
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Your Dynamic Arm Results:

Ollin” Dual Monitor Arm

Mount: Surface Clamp Finish: White

View in Silver Finish »
View in Black Finish »
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Ollin®Dual Monitor Arm

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Dynamic Monitor Arms

Through Mount Grommet

< Return to Main Menu | More Information )
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Your Dynamic Arm Results:

Ollin” Dual Monitor Arm

Mount: Surface Clamp Finish: Black

View in Silver Finish »
View in White Finish »
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Ollin®Dual Monitor Arm

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Dynamic Monitor Arms

Through Mount Grommet

< Return to Main Menu | More Information )
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Your Dynamic Arm Results:

Ollin” Dual Monitor Arm

Mount: Surface Clamp Finish: Silver

View in Black Finish »
View in White Finish »
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Ollin®Dual Monitor Arm

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Dynamic Monitor Arms

Through Mount Grommet

< Return to Main Menu | More Information »
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Dynamic Monitor Arm

Dual Monitor Arm Options

Dynamic Monitor Arms

2 Flo Single
Monitor Arm

When using monitors 22"
and larger, two single screen
arms allow for greater
workspace customization,
while providing the ability
to adapt as technology
changes.

View )

{ Return to Main Menu

Flo Dual
Monitor Arm

For a dual screen workspace
with a clean aesthetic, the

Flo Dual offers a compact
support system with a

maximum recommended
screen size of under 22”.

View »

Flo Dual Monitor
Modular Arm

For workspaces with
monitors under 22”

that require additional
attachment solutions, the
Flo Dual Modular is available
in a variety of mounting
options to attach to various
worksurfaces.

View )

Flo Plus Dual
Monitor Arm

Two monitors that each
range between 4.5- 9 kgs
that move in tandem with
each other are supported by
Flo Plus Dual. Flo Plus Dual
can hold two monitors up to
24" each.

View )

Ollin Dual
Monitor Arm

With the Ollin Monitor Arm,
you can support a range of
monitors and laptops from

0 -9 kg. You can attach a
dual-screen mount to the
main arm to enable moving
two monitors horizontally and
vertically, or tilting in tandem.

View »
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Static Monitor Arms

Select your weight requirement

0-6.5kgs
6.5-12 kgs

12 - 24 kgs

{ Back

Static Monitor Arms
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Static Monitor Arms

Static Monitor Arms

Select your weight requirement

White
0-6.5kgs Grey
Black

{ Back
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Static Monitor Arms

Static Monitor Arms

Static Arms: 0 - 6.5 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

< Back @
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Static Monitor Arms

Static Monitor Arms

Static Arms: 0 - 6.5 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

< Back @
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Static Monitor Arms

Static Monitor Arms

Static Arms: 0 - 6.5 kgs

How many monitors will you be using?

1 Monitor 2 Monitors

< Back @
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Static Monitor Arms

Static Monitor Arms

Static Arms: 6.5 - 12 kgs

How many monitors will you be using?

1 Monitor 2 Monitor 4 Monitors

< Back @
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Static Monitor Arms

Static Monitor Arms

Static Arms: 6.5 - 12 kgs — 2 Monitors

Do your monitors need focal depth adjustment?

< Back @
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Static Monitor Arms

Static Monitor Arms

Static Arms: 6.5 - 12 kgs — 4 Monitors

Do your monitors need focal depth adjustment?

< Back @
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Static Monitor Arms

Static Monitor Arms

Static Arms: 12 - 24 kgs

How many monitors will you be using?

1 Monitor 2 Monitor 4 Monitors

< Back @
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Your Static Arm Results:
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Wishbone®Single Monitor Arm
Mount: Surtace (lamp For a price sensitive alternative on

Finish: Silver monitors up to 8 kgs, also try:

Daisyone” Single
Monitor Arm

Mount: Surface Clamp
Finish: Silver

Daisyone Mount Options »

Email HMI Sales »
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®

Wishbone®Single Monitor Arm

Static Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Locale

< Return to Main Menu | More Information >  Email HMI Sales > @
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Daisyone” Single Monitor Arm

Static Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Locale

< Return to Main Menu | More Information >  Email HMI Sales > @
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Your Static Arm Results:

Wishbone®Plus Single Monitor Arm

Mount: Surface Clamp Finish: Silver

< Return to Main Menu | More Information >  Email HMI Sales > “
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Wishbone®Plus Single Monitor Arm

Static Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Locale

N
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Your Static Arm Results:

I_i m a® Sin gle MOn itor Arm Available in Surface Clamp Only

Mount: Surface Clamp Finish: White

View in Black Finish »
View in Grey Finish »
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Your Static Arm Results:

Lima®Single Monitor Arm

Mount: Surface Clamp Finish: Black

View in Grey Finish »
View in White Finish »

Available in Surface Clamp Only
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Your Static Arm Results:

|_| ma® Sln gle Mon itor Arm Available in Surface Clamp Only

Mount: Surface Clamp Finish: Grey

View in Black Finish »
View in White Finish »
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Static Monitor Arm

Single Monitor Arm Options

-I

Daisyone Single
Monitor Arm

The Daisyone Dual Monitor Arm
is a competitively priced static
monitor arm that allows for focal

adjustment on monitors up to
8 kgs.

View »

{ Return to Main Menu

Wishbone Single
Monitor Arm

The Wishbone Single Monitor Arm
is a scalable static monitor arm that
allows for focal adjustment on
monitors up to 12 kgs.

View »

Wishbone Plus
Single Monitor Arm

The Wishbone Plus Single Monitor
Arm is a scalable static monitor arm
that allows for focal adjustment on
monitors up to 24 kgs.

View »

Static Monitor Arms

Lima Single
Monitor Arm

The Lima Single Monitor Arm is an
easy to install, all in one box static
monitor arm that supports monitors
up to 6.5kg. A second extension arm
can easily be added to the Lima post
without tools to create a dual screen
solution.

View »
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Your Static Arm Results:

Wishbone®Dual Monitor Arm

Mount: Surface Clamp Finish: Silver
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®

Wishbone®Dual Monitor Arm

Static Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Locale
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Your Static Arm Results:

Wishbone®Dual Bar Monitor Arm

Mount: High Load Clamp

{ Return to Main Menu

Finish: Silver

More Information >

Email HMI Sales »

Mount Options » All Static Dual Arms »
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Wishbone®Dual Bar Monitor Arm

Static Monitor Arms

High Load Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% monitor arm sales.
It is shown with the high load clamp which £
provides extra stability, especially for adding
monitors to the post.

Additional Mounts

Through Mount Grommet Locale
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Your Static Arm Results:

Wishbone®Plus Dual Monitor Arm

Mount: Surface Clamp Finish: Silver
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Wishbone®Plus Dual Monitor Arm

Static Monitor Arms

Surface Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% of our monitor arm
sales. This attachment style allows monitors to be
spaced anywhere along the back edge of the desk.

Additional Mounts

Through Mount Grommet Locale
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Your Static Arm Results:

|_| m a® D Ual Mon itor Arm Available in Surface Clamp Only

Mount: Surface Clamp | Finish: White

View in Black Finish »
View in Grey Finish »
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Your Static Arm Results:

|_| m a® D Ual Mon itor Arm Available in Surface Clamp Only

Mount: Surface Clamp | Finish: Black

View in Grey Finish »
View in White Finish »
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Your Static Arm Results:

|_| m a® D Ual Mon itor Arm Available in Surface Clamp Only

Mount: Surface Clamp | Finish: Grey

View in Black Finish »
View in White Finish »
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Static Monitor Arm

Static Monitor Arms

Dual Monitor Arm Options

Daisyone Dual Wishbone Dual Wishbone Dual Bar Wishbone Plus Lima Dual
Monitor Arm Monitor Arm Monitor Arm Dual Monitor Arm  Monitor Arm
The Daisyone Dual Monitor The Wishbone Dual Monitor ~ The Wishbone Dual Bar The Wishbone Plus The Lima Dual Monitor Arm
Arm is a competitively priced  Arm is a scalable static Monitor Arm positions two Dual Monitor Arm is a is an easy to install, all in
static monitor arm that monitor arm that allows monitors at the proper scalable static monitor one box static monitor arm
allows for focal adjustment for focal adjustment on ergonomic height, making arm that allows for focal that supports monitors up to
on monitors up to 8 kgs. monitors up to 12 kgs. it an ideal solution for adjustment on monitors 6.5kg.

those that do not need up to 24 kgs.

focal depth adjustment on
monitors up to 12 kgs and

24” wide each.
Email HMI Sales » View » View » View » View »
ANV (Q)
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Your Static Arm Results:

Wishbone’ Quad Monitor Arm

Mount: High Load Clamp Finish: Silver
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Wishbone®Quad Monitor Arm

Static Monitor Arms

High Load Clamp Mount

The Surface Clamp is our most popular attachment -
bracket — accounting for 80% monitor arm sales. :
It is shown with the high load clamp which 4 LB
provides extra stability, especially for adding
monitors to the post.

Additional Mounts

M

Through Mount Grommet Locale
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Your Static Arm Results:

Wishbone®Dual Bar Quad Monitor Arm

Mount: High Load Clamp Finish: Silver
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Wishbone®Dual Bar Quad Monitor Arm

Static Monitor Arms

High Load Clamp Mount

The Surface Clamp is our most popular attachment | ~
bracket — accounting for 80% monitor arm sales. -
It is shown with the high load clamp which &

provides extra stability, especially for adding
monitors to the post.

Additional Mounts

Through Mount Grommet Locale
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Your Static Arm Results:

Wishbone®Plus Quad Monitor Arm

Mount: High Load Clamp Finish: Silver
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Wishbone®Plus Quad Monitor Arm

High Load Clamp Mount

The Surface Clamp is our most popular attachment
bracket — accounting for 80% monitor arm sales.
It is shown with the high load clamp which
provides extra stability, especially for adding
monitors to the post.
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Additional Mounts

Static Monitor Arms
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Through Mount Grommet
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Static Monitor Arm

Quad Monitor Arm Options

Daisyone Quad
Monitor Arm

The Daisyone Quad Monitor Arm
is a competitively priced static
monitor arm that allows for

focal adjustment on monitors
up to 8 kgs.

Email HMI Sales »

{ Return to Main Menu

Wishbone Quad
Monitor Arm

The Wishbone” Quad Monitor Arm
is a scalable static monitor arm
that allows for focal adjustment on
monitors up to 12 kgs.

View »

Wishbone Dual Bar
Quad Monitor Arm

The Wishbone Dual Bar Quad
Monitor Arm positions four
monitors at the proper ergonomic
height, making it an ideal solution
for those that do not need focal
depth adjustment on monitors up
to 12 kgs and 24” wide each.

View »

Static Monitor Arms

Wishbone Plus
Quad Monitor Arm

The Wishbone Plus Quad Monitor
Arm is a scalable static monitor arm
that allows for focal adjustment on
monitors up to 24 kgs.

View »
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